Jump to content


Photo

[RESOLVED] Membership Exclusives


  • Please log in to reply
13 replies to this topic

#1 HardContact0311

HardContact0311

    Swabbie

  • Crew Member
  • 34 posts
  • LocationLouisiana

Posted 02 March 2012 - 05:15 AM

I didn't know where to post this so I guess this is probably the best spot. Ive been a Crew Leader since the end of February, and a forum member since last November. And I haven't really tried to access anything in the Membership Exclusives area. Then when I received an email about the Crew Leaders T-Shirts I wanted to get one. Then I found out that every time I click on anything in the ITS Community/Membership Exclusives box on the right side of the screen, it just brings me back to the home page. I sent an email a week ago about this problem but haven't heard anything on it yet. I don't know if its a problem with the website or I'm just an idiot with a computer. I really would like to order the Crew Leader shirt soon. Thanks for any info guys
Posted Image
Pain is weakness leaving the body

#2 CENTCOMSurvivor

CENTCOMSurvivor

    Down Wit' Da Hui

  • Moderator
  • 947 posts
  • LocationTampa/St Petersburg Florida

Posted 02 March 2012 - 05:40 AM

Send Rob an email: [email protected] He can look into it for you. Thanks
Posted Image

#3 Rob Henderson

Rob Henderson

    Salty Dog

  • Administrator
  • 346 posts

Posted 02 March 2012 - 06:12 AM

Hey HC, Looks like there was something going on with your Forum and Membership Permissions. I've gotten everything reset and you should be good to go now! Sorry about the lack of communications, we've just been really slammed here at HQ with emails and we're working through the backlog! Thanks for your support!
Posted Image

#4 HardContact0311

HardContact0311

    Swabbie

  • Crew Member
  • 34 posts
  • LocationLouisiana

Posted 02 March 2012 - 07:15 AM

I used to work with customers/retail environment and I completely understand. But it's all good, the problem has been fixed and I just ordered my Crew Leader shirt and 8.6.11 patch. Thanks again for the help guys…looking forward to my box of awesome /wp-content/forum-smileys/anim_beer.gif

Edited by HardContact0311, 02 March 2012 - 07:30 AM.

Posted Image
Pain is weakness leaving the body

#5 swimr235

swimr235

    Landlubber

  • Crew Leader
  • 14 posts
  • LocationI dunno...south...the deepest of souths.

Posted 28 June 2013 - 08:38 AM

Having the same issues. Actually, the whole new layout threw me for a loop. Any help or a link to them would be much appreciated. I cant seem to navigate this properly.

- nick :headbang:
“Audentes fortuna iuvat”
- Virgil

#6 Rob Henderson

Rob Henderson

    Salty Dog

  • Administrator
  • 346 posts

Posted 28 June 2013 - 10:07 AM

Hi Swimr,

I'll add some pictures with the steps for logging into the new site, as your account may be logged in on the Forum but not the site since they're separate.

First you'll need to sign in by clicking the little silhouette in the upper right hand corner of the homepage.

Posted Image


Next you'll need to enter your log in information. This may be separate from your Forum Information. If you don't have the info, send us an email at support(at)itstactical.com and we'll get your account straightened out.

Posted Image



This is the new dashboard and there you'll see Membership Exclusives on the right. Please note that in order to access the ITS Discount code and to view the announcements, you'll need to click the plus sign next to announcements.

Posted Image
Posted Image

#7 swimr235

swimr235

    Landlubber

  • Crew Leader
  • 14 posts
  • LocationI dunno...south...the deepest of souths.

Posted 28 June 2013 - 02:57 PM

Mr. Dog,
I sincerely appreciate your help. It is a very clear and concise set of instructions. I dont see those screens and im starting to think that it may be my web browser thats limiting me. I sincerely do not see any of that. All I see is a mess of a webpage to be honest. I cant click icons and I cant find or click the login unless i literally google "its tactical login". All I can see are whats under "The Latest" and thats it. Nothing else. I think it may be a browser issue for me and not the website. For some reason the old site wasnt an issue for me. I was able to pull up member exclusives on my phone today also, with no issues.

- nick :headbang:
“Audentes fortuna iuvat”
- Virgil

#8 mikejulietpapa

mikejulietpapa

    Salty Dog

  • Life Member
  • 719 posts
  • LocationDE

Posted 02 July 2013 - 01:34 PM

swimr235, it might be a browser issue with the new site. We're still going around cleaning up little bugs that keep popping up but it sounds like it's displaying really crazily for you. What kind of computer and browser are you using?

#9 WillE6

WillE6

    Landlubber

  • Crew Leader
  • 5 posts

Posted 05 February 2014 - 12:15 PM

I am having a similar issue, I keep trying to sign into the it's tactical sight and I keep getting an error message so I am not sure if I am entering the right sign in information or if I don't have permission to access the dashboard. I am trying to access the discount code for the battle mug. Any help would be appreciated so I can represent my crew leader status in style.

#10 mikejulietpapa

mikejulietpapa

    Salty Dog

  • Life Member
  • 719 posts
  • LocationDE

Posted 06 February 2014 - 09:46 AM

I am having a similar issue, I keep trying to sign into the it's tactical sight and I keep getting an error message so I am not sure if I am entering the right sign in information or if I don't have permission to access the dashboard. I am trying to access the discount code for the battle mug. Any help would be appreciated so I can represent my crew leader status in style.

 

Have you been trying to login through the main site? 

 

Follow the instructions on this tutorial and let me know if you're still having issues. >> How to Access the Discount Code Page



#11 WillE6

WillE6

    Landlubber

  • Crew Leader
  • 5 posts

Posted 06 February 2014 - 10:32 AM

I have been trying to login through the main site but every time I do it tells me invalid username or password. I am not sure if I am supposed to register somewhere else also. When I try to click the link from the support page straight to the dashboard it takes me to a screen to sign up for a membership. To be honest I am really confused on what I am doing wrong.

#12 mikejulietpapa

mikejulietpapa

    Salty Dog

  • Life Member
  • 719 posts
  • LocationDE

Posted 06 February 2014 - 11:11 AM

I have been trying to login through the main site but every time I do it tells me invalid username or password. I am not sure if I am supposed to register somewhere else also. When I try to click the link from the support page straight to the dashboard it takes me to a screen to sign up for a membership. To be honest I am really confused on what I am doing wrong.

 

Sorry about the sign in issues.

 

UPDATE: I just talked with Rob and he filled me in on what's going on. The Site and Forum require separate registrations. They can be the same username but it's up to you to register it first. 

 

To fix this issue and get you the proper permissions, visit this link and create a free membership account. Once you do that, send an email to [email protected] letting us know of your usernames and we'll get you squared away.

 

Thanks for your patience!


Edited by mikejulietpapa, 06 February 2014 - 11:28 AM.
Updated Info


#13 WillE6

WillE6

    Landlubber

  • Crew Leader
  • 5 posts

Posted 07 February 2014 - 12:39 AM

I followed the link and created and set up the free account with its tactical under username WILLE6. My username for the forum is WillE6. Hopefully that will enable me to get squared away with the proper permissions if not let me know and I will get it done. Thank you for all your help with these issues.

#14 mikejulietpapa

mikejulietpapa

    Salty Dog

  • Life Member
  • 719 posts
  • LocationDE

Posted 07 February 2014 - 12:19 PM

Looks like you're all set WillE6! Thanks for your patience!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users